Bongofish

Screen Tablet malarky => Heyaaaalpppp => Topic started by: bedii on April 06, 2009, 01:31:48 AM



Title: UD1212R Skipping.
Post by: bedii on April 06, 2009, 01:31:48 AM
I recently bought three 1212R's from a supplier without pens, cables, or power supplies in the hopes I could get at least one of them working.  The other day someone on Craigslist in my area offered a complete 1212R setup for less than I could get the pen for so I bought it as well.  It turns out that three of the tablets work perfectly using Tablet Magic on my Mac, but the fourth skips all over the screen when I try to move the cursor with the pen.  Before I consign this 1212R to the junkpile does anyone know what might be causing this and what I could do to take care of the problem?  I've tried many of the settings in the Testing screen of Tablet Magic with no success: self-test works, but when I move the pen it looks like the pad is connecting and disconnecting at a rapid rate.  That would explain why it skips but I don't know what steps to take to eliminate the problem...


Title: Re: UD1212R Skipping.
Post by: Claymonkey on April 06, 2009, 04:22:25 PM
Have you run the UDconfig utility on the tablets?

http://forum.bongofish.co.uk/index.php?topic=90.0

You can get this to run off a bootable flashdrive pretty easy.  Compare the settings of the three tablets that are working to the one that's being flakey. Anything different?

Though now that I think about it Tabletmagic has a lot of the details/settings you can get from udconfig listed under tablet protocol.

Other things you can look at are are the contacts of the serial port clean on the tablet? If you open it up does everything look fine? Broken contacts? 

If you're going to much electronics work I highly recommend having a can of something like this around: http://www.amazon.com/CRC-Industries-05103-Electronic-Cleaner/dp/B000BXOGNI/ref=pd_bbs_sr_2?ie=UTF8&s=automotive&qid=1239030918&sr=8-2  which you can just spray on leads or components, let fully dry (actually does this quickly) and then try again. Other cheaper options are pink erasers and isopropyl alcohol or nail polish remover, you probably have at least some of these in your house already. Only problem with them is you can't easily clean IN the serial port connectors.


Title: Re: UD1212R Skipping.
Post by: iRoc on May 04, 2009, 12:35:30 AM
Have you tried a different set of connections. i.e. the power adapter and serial cables. Could be a short in a wire from being coiled. People tend to do that with wires, but it's the worst thing to do to them, especially if they have thin wires. Just a thought.


Title: Re: UD1212R Skipping.
Post by: bedii on May 04, 2009, 04:32:39 AM
Clqymonkey:

After working with a nice gent from Wacom, who checked if there were any replacement parts available (there aren't), after setting up an OS 9 Mac to use the Wacom software (no change), and after opening up the tablet and checking the contacts I found something that may be a possible explanation: Wacom hasn't given me an opinion one way or the other on this one, so it's just theory at this point.  What I found is that there's a ROM difference between the tablets: the ones that work show the model and ROM version ~#UD-1212-R00 V1.2-0 and the one that doesn't shows ~#UD-1212-R00 V1.1-1.  So this tablet may work fine for someone with a Windows setup, for example, but the V1.1-1 ROM seems to truly hate Macs.  If I could find someone who wants to swap tablets we'd know for sure...

iRoc:

The power adaptor and serial cables work perfectly on three other tablets.  It's something about this one, not the cabling.


Title: Re: UD1212R Skipping.
Post by: Drewid on May 06, 2009, 09:14:09 PM
Are the ROMs flashable on tablet?


Title: Re: UD1212R Skipping.
Post by: Claymonkey on May 07, 2009, 03:33:45 PM
Good question Drew. 

They use eeprom chips of a model after the ones that needed light programmers. I don't have the info handy but I recall looking at the 3 I have between tablets that these are rewritable and not write once style chips.

Can you reprogram them on the boards? I don't know. I'm still learning chip programming from a ground up level (mostly from my cintiq project leading to other interests). Anyone with more experience with this on the boards?

However, Theoretically you could use a Willem programmer to read the data off of these. I have 2 UD1212 at ROM 1.4 and the UD1218 at 1.2. If I remember correctly the 1.2 is when they introduced pressure sensitivity but you don't get tilt control or use of the eraser.

Bedii. If you feel brave you can try swapping the rom chip from a working tablet to the flakey one. IF you do this don't use a chip pull tool since they tend to bend pins. Slowly lift the chip from the socket by sliding a flat head screwdriver/knife first under one side and then the other. Repeat until you can easily pop the chip out of the socket without bending pins. If you do bend a pin you can bend it back. Just be careful because you don't want to over tax it and break a pin off. Slow and steady.

The other option is to take the whole control board from one and try it on the flakey tablet just to make sure its not the actual board itself.

Lastly stupid question time. I assume you tried different cables and power from the working tablets?


Title: Re: UD1212R Skipping.
Post by: bedii on May 09, 2009, 06:37:17 AM
Claymonkey:

I'd rather avoid swapping chips if necessary: I have one tablet not working and three working and would hate to end up with 2 and 2.  I may try swapping the control boards soon.  As far as the power supply and the cables go, I only have the one set: it works fine on the other three tables which leads me to assume the cabling is correct.


Title: Re: UD1212R Skipping.
Post by: Claymonkey on May 11, 2009, 04:01:03 PM
I agree about not wanting to break one board testing another. Swapping boards shouldn't do that however. Besides, if you're building a cintiq you should be taking these apart anyway.

I gave you all the details because... well most of us tinker because we can't help it. I'd rather you know the pitfalls and things to watch out for than brick it.