Screen Tablet malarky => Heyaaaalpppp => Topic started by: DaBotz on July 09, 2014, 01:38:16 PM

Title: Intuos2 stopped reading tools serial numbers
Post by: DaBotz on July 09, 2014, 01:38:16 PM
I found out, finally, that the Intuos 2 in UBiQ does not read the serial numbers any more (which is the reason why it stopped working in Ubuntu; The Linux driver stops, while the Windows driver just assigns a Bogus serial number 0x00000001 and keeps working - if you use just one pen, like me, there is no way to see it unless you go looking for the actual serial number).

I suspect that it would need some kind of reset (I found some references about a hardware reset button, that on my tablet was replaced by a simple cover for its hole, and to a "Recalibrate" button in  the windows driver panel, under "About"=>"Test" - that is not there in the driver I installed, 6.2.0w5).

Apparently, it is something that happens to Intuos and Intuos2, once in a while (hence the Recalibrate/Reset of old drivers... Apparently, it did a pretty thorough reset, as I found a page where it was used to fix a situation that look exactly like my situation in Linux).

Anyone can tell me more on how to fix this (if it can be fixed)?

Which driver is more likely to work on modern OS and still have the general Recalibrate button?

Did intuos2 have a hardware reset button that  I overlooked? If they do, where was it?
The oval spot on the right of the USB cable, right?

As long as no more shit happens, I'll just keep using Windows (but the Linux driver was so nice... You could script almost whatever you wanted, so I had "made a button" to switch screen/projection/tracking mode, another to change the knob controls mode - exactly like the intuoses with buttons do, and as it allowed a logical area bigger than the physical area of the tablet, one needn't struggle with the screen projection to accommodate for a larger than tablet screen - so you could change screen resolution, if needed, without having to recalibrate anything), but I rather fix it, if it is possible.

Anticipated thanks for everything, pals.


Title: Re: Intuos2 stopped reading tools serial numbers
Post by: Aerendraca on July 09, 2014, 01:55:01 PM
Apparently this has been a problem since Ubuntu 10.10. I've found what appears to be a workaround here:
I'm not sure if this is even useful to you as I'm not a Linux user but it looks promising.

As for the Oval on the side of the Intuos2, I'm afraid that this is just a decorative piece that perhaps served the function of being a space for a serial socket in initial designs. I can confirm that on my I2 A4 Oversize there are no hardware resets buttons and I would expect this to be the case for other sizes too.

Title: Re: Intuos2 stopped reading tools serial numbers
Post by: DaBotz on July 09, 2014, 05:43:38 PM
I already tried that workaround, but it didn't work for me.

I tried to manually patch the driver, replacing the simple logic

"Ignore syn event if serial id = 0" with a more subtle "if no valid id has ever been received, assign default id 1, and may God be with us; if a valid Id has been received once, something really stinks" [having fun with pseudocode] but I can't seem to be able to convince the damn wacom.ko to go in the right place (probably, I have to build the driver again, and manually copy the various where they need to go - grrrrrrrr ).

By the way, the fact that the wacom drivers assign id 1 to all tools seems to indicate that it does the same.

Anyway, I had already decided to switch back to Windows because my Photoshop Elements doesn't read pressures in Ubuntu, and I can't really use the smudge tool of GIMP for all my works, as I do not really seem to get its logic (more or less, Photoshop simulates pulling oil colours on canvas, GIMP is a lot more like "running" watercolours on paper; I still suck with it, though it is a lot less of a resource-hog than the PE one).

My main worry was that it was - maybe - a symptom of something going astray with the tablet.

On a happier note, I have passed through my preferred computer shop and "stole" a couple of burnt PC power sources (they pop like popcorns, round here) to harvest more ferrite toruses.

I built some more common chokes on my usb cable, and the base jitter of my UBiQ has gone down noticeably (below that of my hand, apart near the CCFL tubes).

I'm thinking about buying a usb extension, strip the  cable external protection, and wind as many coils I can, to see if it can be lowered further this way.